OPEN HYPER TERMINAL OR PUTTY TO TAKE THE
CONSOLE OF ROUTER …………………………………….
TYPE ‘NO’ AND ‘RETURN’ TO COME ON USER
MODE FROM SETUP MODE
Three Different Ways to Connect to A Cisco Router
- Console
port
- Auxiliary
port
- Telnet
Console port
- Usually
a RJ45 connection on the back of the router
- It
is used to directly connect and configure the
- Router no password is set on the console by default
Auxiliary port
- It is
usually a RJ45 connector on the back of the router.
- It is
used to connect and configure the router remotely via modem
- It
must be configured using console port before it can be used
- The
speed of this port can be set as high as 15200bps on some devices
- No
password is set by default; password is required to be set.
Telnet
- It is
an emulation program that emulates a dumb-terminal
- Ones
telnet session is established we can connect to any active interface
(Ethernet or serial) on the router.
- Several concurrent telnet connection to a router are allowed
Preparing the router for initial configuration
We need to obey the following guidelines before bringing up
a router:
Step 1
Verify the power, cabling and console connection
Step 2
Switches on the power switch
Step 3 Observe the following boot sequence:
Step3.1 POST
Step3.2 Find
& load IOS image from flash memory. Router uses it for it’s operating system
Step3.3 Look
for a valid configuration called startup-configuration that is stored in NVRAM.
This configuration statement give router’s specific attributes, protocol
functions and interface addresses.
If there is no configuration in NVRAM, the router will
automatically enter to “Setup mode”.
We can also enter in to Setup mode at any time by typing
“setup” command at the privileged EXEC mode. (Router # setup)
Setup mode can be either:
Basic
Extended
Given below is the list of some global parameters that can
be configured:
- Set
the router host name
- Set
various passwords:
i.
Set enable secret
ii.
Set enable password
iii.
Set virtual terminal password
- Configure
initial protocols e.g. SNMP, LAT, AppleTalk, DECnet, IP, IGRP routing etc.
- Configure
additional protocols
- Configure interface parameters
Finally router shows the new configurations and ask, whether
you want to save to NVRAM.
Logging in to the Router
Two types of user interfaces are:
- User
mode
- Privileged mode
Movement from user mode to privileged mode and vice versa is
shown below:
Router> (user mode)
Router>enable
Router# (privileged mode)
Router #disable
Router>
Type logout to exit the console
Router>logout
Keyboard help in Router Command –Line Interfaces
Cisco IOS software include following command-line input help
facilities:
- Context
Sensitive Help
- Console
Error Messages
- Command History Buffers
Context Sensitive Help
- For
word help- Type-?
- For command syntax help-Type___? (after space)
Console Error Messages
- %
Ambiguous command
- %
Incomplete command
- % Invalid input detected at “^” marker
Command History Buffers
- Set
the command history buffer size
- Recall
commands
- Disable
the command history feature.
Command
|
Functionality
|
Ctrl+p or up-arrow
|
Last (previous) command recall
|
Ctrl+n or down-arrow
|
More recent command recall
|
Router>show history
|
Show command buffer
|
Router>terminal history size lines
|
Set command buffer size
|
Router>no terminal editing
|
Disable advanced editing
|
Router>terminal editing
|
Re-enable advanced editing
|
<Tab>
|
Entry Completion
|
Command Line
Editing Key
Sequence
|
Description
|
Ctrl+a
|
Moves the cursor to the beginning of the line
|
Ctrl+e
|
Moves the cursor to the end of the line
|
Ctrl+f
|
Moves the cursor forward one character
|
Ctrl+b
|
Moves the cursor backward one character
|
Esc+f
|
Moves the cursor forward one word
|
Esc+b
|
Moves the cursor backward one word
|
Ctrl+d
|
Deletes a single character
|
Ctrl+k
|
Deletes everything to the right of the line
|
Ctrl+x
|
Deletes everything to the left of the line
|
Ctrl+w
|
Deletes a word
|
Ctrl+u
|
Deletes a line
|
Ctrl+r
|
Refreshes the command line and everything typed up to this
point
|
Backspace
|
Removes one character to the left of the cursor.
|
Tab
|
Completes a partially entered command if enough characters
have been entered to make it unambiguous
|
Commands to get basic Router Information
Router #show version
Router #show running-config
Router #show startup-config
Router
Configuration commands from CLI
LAB EXERCISE 1
User Exec Mode Prompt…
Router>
How to reach Privileged EXEC Mode (Enable Mode)…
Router>enable
Router#
How to reach User EXEC Mode…
Router #disable
Router>
How to reach Global Configuration Mode…
Router #config terminal
Router (config) #
How to reach other configuration mode…
1.Line configuration mode
Router (config) #line <type of line to be configured>
<line no.>
Router (config-line) #
2.Interface configuration mode
Router(config)#interface serial 0
Router(config-if) #
Return to previous mode
Type ‘exit’ at any stage
Monitoring the Router
1.Current IOS version
Router #show version
2.Contents of Flash
Router #show flash
3.Contents of RAM
Router #show buffers
Router #show stacks
4.Displaying the startup configuration
Router #show startup-config
5. Displaying the running configuration
Router #show running-config
6.Monitor interface parameters
Router>show <interface type slot no./port no.>
Setting Password:
1.Enable Password
Router(config) #enable secret <cisco>
2.Enable Secret
Router(config) #enable password <shree>
3.Auxiliary Password
Router(config) #line aux 0
Router(config-line) #login
Router(config-line) # password <shree>
5.Console Password
Router(config) #line console 0
Router(config-line) #login
Router(config-line) #password <shree>
6.Other console port Password
Router(config) #line console 0
Router(config-line) #exec-timeout 0 0
Router(config-line) #logging synchronous
7.Telnet Password
Router(config) #line vty 0 197
Router(config-line) #login
Router(config-line) #password <shree>
Router(config-line) #no login
Banner Setting
e.g.
Router(config) #banner motd #Even Impossible says I M
possible.#
Hostname
Router(config) #hostname <shree>
Configuring Router Interfaces
Router(config) #interface <interface type slot
no./port no.>
Router(config-if) #no shutdown
e.g.
Router(config) #interface Ethernet 0
Router(config-if) #no shutdown
Router(config) #interface serial1
Router(config-if) #no shutdown
Bringing up an Interface
Router #sh int e0
Router(config) #int e0
Router(config-if) #no shutdown
Configuring an IP Address on an interface
Router(config-if) #ip address <A.B.C.D> <subnet
mask>
e.g.
Router(config) #int eo
Router(config-if) #ip address 192.168.10.10 255.255.255.0
Router(config-if) #no shutdown
Router(config-if)ip address 192.168.10.10 255.255.255.0
secondary
Setting Clock rate
Router(config-if)clock rate 64000
Setting Bandwidth
Router(config-if) #bandwidth 64
Description
Router(config) #int e0
Router(config-if) #description <Sales LAN>
CDP Commands:
Router #show cdp neighbors
Router # show cdp neighbors details
Router #show cdp traffic
Router #show cdp entry
Router #show cdp interface
Telnet to another Router:
Router #tenet <ip address of any interface on the other
router>
Monitoring Connections:
Router #show sessions
Router #show users
Suspend a connection:
Router2 #ctrl+shift+6 then X
Router1 #
Resume a connection:
Router1 #resume <session no.>
Router2 #
End a connection:
Router2 #exit
Router1 #
Or
Router1 #disconnect <ip address of the other router>
Enabling logging messages on the current terminal line:
Router #terminal monitor
Disabling logging messages on the other terminal line:
Router #terminal no monitor
Disabling logging messages on Console:
Router #no logging console
Testing
Connectivity:
Testing Network layer connectivity through Ping
Router >ping <ip address/name>
Basic Configuration Commands:
Configuring name of the router
Router(config) #hostname <name string>
Configuring name address mapping
Router(config) # ip host <name of the host> <ip
address of the host>
Back up
Backing up Router Configuration on TFTP server
Router #copy running-config tftp
Router # copy startup-config tftp
Backing up IOS image file from Flash memory
Router #copy flash tftp
Restoring backed up configuration to running-configuration
Router #copy tftp running-config
0 Comments